The Elearning Community • AGGIORNAMENTO A FORMA 1.4 - Gestione Report - Organigrammi
Page 1 of 2

AGGIORNAMENTO A FORMA 1.4 - Gestione Report - Organigrammi

Posted: Mon May 11, 2015 10:05 am
by s.posti
Ciao a tutti, dopo un'upgrade da Forma 1.3 alla 1.4 (eseguito con successo) ho testato tutto (credevo) e riaperto la piattaforma; peccato che mi sono accorto stamane che i Report salvati non visualizzano più dati, e che se provo a ricrearli selezionando i nodi degli organigramma non viene estratto nulla; Funziona soltanto il Report "per Tutti gli utenti".
Qualcuno ha riscontrato tale anomalia o ha qualche idea?
Grazie infinite

Stefano

Re: AGGIORNAMENTO A FORMA 1.4 - Gestione Report - Organigram

Posted: Tue May 12, 2015 2:13 pm
by danilo
Anche io ho un problema simile. Avevo un report che mi mostrava lo status degli appartenenti ad uno specifico gruppo rispetto ai corsi. Ora compare "Non ci sono valori nella selezione".
Ricreandolo ottengo lo stesso risultato, nessun dato.

Re: AGGIORNAMENTO A FORMA 1.4 - Gestione Report - Organigram

Posted: Tue May 12, 2015 3:10 pm
by CisterNino
A quale tipo di report vi riferite ? "Utenti" , "Corsi", "Aggregazione dei dati per utenti e per corsi ?"

Re: AGGIORNAMENTO A FORMA 1.4 - Gestione Report - Organigram

Posted: Tue May 12, 2015 4:20 pm
by danilo
Personalmente mi riferisco ad uno specifico report che aggrega i membri di un gruppo con i corsi cui sono iscritti, mostrando una griglia: Nome, Cognome, Corso, Primo accesso, Data completamento, Punteggio test finale, Tempo totale.

Un altro report uguale, ma basato su tutti gli utenti funziona correttamente.

Re: AGGIORNAMENTO A FORMA 1.4 - Gestione Report - Organigram

Posted: Wed May 13, 2015 9:53 am
by CisterNino
Danilo,
nella definizione degli utenti hai utilizzato dei campi aggiuntivi ?

Re: AGGIORNAMENTO A FORMA 1.4 - Gestione Report - Organigram

Posted: Wed May 13, 2015 12:38 pm
by s.posti
Io uso tutti report uguali x diversi nodi degli organigrammi, si tratta del classico report Utenti\Corsi e si, ci sono ovviamente anche i campi aggiuntivi. non funziona più nulla se non i report "per tutti gli utenti". la selezione per i corsi è ok , a mio avviso il bug è proprio relativo al parsing del db utenti, non ai corsi o all'aggancio dei campi aggiuntivi.

Re: AGGIORNAMENTO A FORMA 1.4 - Gestione Report - Organigram

Posted: Wed May 13, 2015 2:08 pm
by CisterNino
Premetto che non avevo dei precedenti report prima dell'aggiornamento alla 1.4 e quindi ho creato dei report ex-novo.
Non sono riuscito a replicare il malfunzionamento. Avete verificato se il problema persiste anche nel caso di nuovi report ?

Re: AGGIORNAMENTO A FORMA 1.4 - Gestione Report - Organigram

Posted: Wed May 13, 2015 2:17 pm
by danilo
Ciao, nei miei report ho dei campi aggiuntivi, ma non sembrano essere i responsabili del malfunzionamento (togliendoli non ho comunque alcun risultato). Il report per il quale ho aperto il post, ho anche provato a rifarlo ex novo, ma senza risultati. Solo selezionando tutti gli utenti ottengo una visualizzazione dei dati (ma non mi occorre in quanto un report per tutti gli utenti era già presente e funzionante).

Re: AGGIORNAMENTO A FORMA 1.4 - Gestione Report - Organigram

Posted: Wed May 13, 2015 5:01 pm
by alberto
Ciao a tutti, probabilmente dipende da uno dei fix di sicurezza introdotti nell'ultima release, potreste provare questa patch e dirci se risolve?

Re: AGGIORNAMENTO A FORMA 1.4 - Gestione Report - Organigram

Posted: Wed May 13, 2015 5:54 pm
by s.posti
Ciao, la Patch di Alberto nella mia installazione ha risolto il problema dei Report, il problema della lista degli Amministratori Pubblici non più visualizzabili, e dei Certificati non scaricabili dagli utenti 8se non con pagine bianche).
Immensi, come sempre!

This site uses cookies.

Some of the cookies we use are essential for parts of the site to operate and have already been set. We also use Google Analytics scripts, which all use cookies.
You may delete or block all cookies from this site in your browser options.