Problema con SC - Domanda a risposta singola

Funzionalità di frontend per utenti e amministratori dei corsi: navigazione generale, materiali didattici, test, registro valutazioni, ecc.
Post Reply
andrea_pg
Newbie
Posts: 9
Joined: Fri Dec 13, 2019 9:14 am

Problema con SC - Domanda a risposta singola

Post by andrea_pg »

Ciao, ho cercato nel forum la soluzione al mio problema ma non sono riuscito a trovarla quindi mi permetto di postarla.

Creando un Test ed in particolare una SC - Domanda a risposta singola, al salvataggio delle modifiche le risposte non sono salvate. A questo punto, tentando di aggiungere nuovamente le risposte, cliccando Aggiungi risposta, viene fatto semplicemente il refresh della pagina senza la possibilità di aggiungere risposte. Si verifica sia in Chrome sia in Firefox.

Viceversa il problema non si verifica creando domande e risposte per un Questionario, quindi SS - Scelta singola, in questo caso funziona sia il primo salvataggio sia la possibilità successiva di modificare e salvare.

Grazie

User avatar
max
FormaLms Guru
Posts: 2405
Joined: Thu Mar 01, 2012 10:41 am
Version: forma.lms 2.4
Contact:

Re: Problema con SC - Domanda a risposta singola

Post by max »

Buongiorno,
francamente non ci risulta, creiamo test ogni giorno ovviamente usando le domande di tipo SC.
Versione di Forma?
Possibile che ci siano questioni di apostrofi, come citato in questo thread? viewtopic.php?f=5&t=13527
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
https://www.elearnit.net
https://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
Skype: m_ferrari_it

andrea_pg
Newbie
Posts: 9
Joined: Fri Dec 13, 2019 9:14 am

Re: Problema con SC - Domanda a risposta singola

Post by andrea_pg »

Grazie della risposta immediata, la versione è la 2.3.0.2
in merito agli apostrofi hai ragione, il problema è legato all'apostrofo nelle risposte. per il momento ho risolto usando ’
successivamente farò l'aggiornamento

User avatar
pexlex
FormaLms User
Posts: 166
Joined: Wed Sep 09, 2015 11:56 pm
Version: forma.lms 2.0

Re: Problema con SC - Domanda a risposta singola

Post by pexlex »

Mi allego alla discussione e anche io riscontro questo problema. Se creo una domanda tipo SC e nel testo ci sono apostrofi non mi salva la domanda.
Versione LMS Forma 2.3.0.2

User avatar
max
FormaLms Guru
Posts: 2405
Joined: Thu Mar 01, 2012 10:41 am
Version: forma.lms 2.4
Contact:

Re: Problema con SC - Domanda a risposta singola

Post by max »

ok, la cosa è fixata su forma 2.4, per la tua versione puoi risolvere come ha fatto l'utente andrea_pg
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
https://www.elearnit.net
https://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
Skype: m_ferrari_it

Post Reply