inserimento accenti e apostrofi

Domande sulle funzionalità di backend: amministrazione utenti e corsi, certificati, iscrizioni, report, ...
Post Reply
info@technimedia.it
Newbie
Posts: 2
Joined: Thu Apr 02, 2020 11:49 pm

inserimento accenti e apostrofi

Post by info@technimedia.it »

Buonasera,

da qualche giorno sto prendendo confidenza con la piattaforma appena installata e sono felicemente sorpreso dall'usabilità e configurabilità del sistema. Ho installato la versione 2.3.

Tutto funziona correttamente ma ho un problema con l'inserimento di lettere accentate ed apostrofi nel solo form per la compilazione delle domande dei test. Il sistema non memorizza e scarta l'inserimento senza nessun avviso. Inserendo senza accenti o apostrofi va tutto in tabella.

Tutti gli form vanno correttamente. Nel database la codifica usata è UTF8_general_ci per tutte le tabelle.

Da cosa potrebbe dipendere?

Grazie per l'aiuto.

alfa24
Senior Boarder
Posts: 1000
Joined: Fri Nov 24, 2017 8:45 am
Version: forma.lms 1.4.2

Re: inserimento accenti e apostrofi

Post by alfa24 »

E' un bug.
Workaround, usa ' nel sorgente.
I'm Jasmines, the One. If you need, you can contact me.

info@technimedia.it
Newbie
Posts: 2
Joined: Thu Apr 02, 2020 11:49 pm

Re: inserimento accenti e apostrofi

Post by info@technimedia.it »

ho aggiunto questo

//Provides:
$val = str_replace("'", ''', $val);

in ../appLms/index.php

ma non funge, sbaglio file?

alfa24
Senior Boarder
Posts: 1000
Joined: Fri Nov 24, 2017 8:45 am
Version: forma.lms 1.4.2

Re: inserimento accenti e apostrofi

Post by alfa24 »

Nel sorgente dell'editor del form di compilazione della domanda...
I'm Jasmines, the One. If you need, you can contact me.

Post Reply