Installation stuck at 7/8 Screen

Install and configure FormaLMS and DoceboCE
rudy
FormaLms User
Posts: 33
Joined: Fri Nov 29, 2019 7:33 am

Installation stuck at 7/8 Screen

Post by rudy »

Hi I am trying to install the 2.4.2 forma lms and installation stucks at 7/8 screen as it says unable to detect smtp, whereas i hv used same setting for my other lms it is working fine. so i check the apache error log, it is showing the below data: please suggest the reason, how to recitfy

[Sat Aug 15 11:39:40.182179 2020] [mpm_event:notice] [pid 1958:tid 139826401397824] AH00489: Apache/2.4.41 (Ubuntu) configured -- resuming normal operations
[Sat Aug 15 11:39:40.183395 2020] [core:notice] [pid 1958:tid 139826401397824] AH00094: Command line: '/usr/sbin/apache2'
[Sat Aug 15 11:58:30.719921 2020] [mpm_event:notice] [pid 1958:tid 139826401397824] AH00491: caught SIGTERM, shutting down
[Sat Aug 15 11:58:30.822535 2020] [mpm_event:notice] [pid 2969:tid 139620868971584] AH00489: Apache/2.4.41 (Ubuntu) configured -- resuming normal operations
[Sat Aug 15 11:58:30.822633 2020] [core:notice] [pid 2969:tid 139620868971584] AH00094: Command line: '/usr/sbin/apache2'
[Sat Aug 15 12:11:46.841532 2020] [mpm_event:notice] [pid 2969:tid 139620868971584] AH00491: caught SIGTERM, shutting down
[Sat Aug 15 12:11:46.946941 2020] [mpm_prefork:notice] [pid 50914] AH00163: Apache/2.4.41 (Ubuntu) configured -- resuming normal operations
[Sat Aug 15 12:11:46.947042 2020] [core:notice] [pid 50914] AH00094: Command line: '/usr/sbin/apache2'
[Sat Aug 15 12:11:47.506126 2020] [mpm_prefork:notice] [pid 50914] AH00169: caught SIGTERM, shutting down
[Sat Aug 15 12:11:47.671189 2020] [mpm_prefork:notice] [pid 50978] AH00163: Apache/2.4.41 (Ubuntu) configured -- resuming normal operations
[Sat Aug 15 12:11:47.671244 2020] [core:notice] [pid 50978] AH00094: Command line: '/usr/sbin/apache2'
[Sat Aug 15 12:18:05.159352 2020] [mpm_prefork:notice] [pid 50978] AH00169: caught SIGTERM, shutting down
[Sat Aug 15 12:18:05.316704 2020] [mpm_prefork:notice] [pid 51656] AH00163: Apache/2.4.41 (Ubuntu) configured -- resuming normal operations
[Sat Aug 15 12:18:05.316759 2020] [core:notice] [pid 51656] AH00094: Command line: '/usr/sbin/apache2'
[Sat Aug 15 12:25:02.783082 2020] [mpm_prefork:notice] [pid 51656] AH00169: caught SIGTERM, shutting down
[Sat Aug 15 12:25:02.935955 2020] [mpm_prefork:notice] [pid 51695] AH00163: Apache/2.4.41 (Ubuntu) configured -- resuming normal operations
[Sat Aug 15 12:25:02.936038 2020] [core:notice] [pid 51695] AH00094: Command line: '/usr/sbin/apache2'
[Sat Aug 15 12:27:09.869884 2020] [mpm_prefork:notice] [pid 51695] AH00169: caught SIGTERM, shutting down
[Sat Aug 15 12:27:10.017709 2020] [mpm_prefork:notice] [pid 51726] AH00163: Apache/2.4.41 (Ubuntu) configured -- resuming normal operations
[Sat Aug 15 12:27:10.017771 2020] [core:notice] [pid 51726] AH00094: Command line: '/usr/sbin/apache2'
[Sat Aug 15 12:31:41.656110 2020] [mpm_prefork:notice] [pid 51726] AH00169: caught SIGTERM, shutting down
[Sat Aug 15 12:31:41.840543 2020] [mpm_prefork:notice] [pid 52226] AH00163: Apache/2.4.41 (Ubuntu) configured -- resuming normal operations
[Sat Aug 15 12:31:41.840604 2020] [core:notice] [pid 52226] AH00094: Command line: '/usr/sbin/apache2'
[Sat Aug 15 12:31:56.191867 2020] [:error] [pid 52227] [client 122.161.161.1:63314] PHP Warning: require(/var/www/html/formalms/lib/../config.php): failed to open stream: No such file or directory in /var/www/html/formalms/lib/lib.bootstrap.php on line 141
[Sat Aug 15 12:31:56.191925 2020] [:error] [pid 52227] [client 122.161.161.1:63314] PHP Fatal error: require(): Failed opening required '/var/www/html/formalms/lib/../config.php' (include_path='.:/usr/share/php') in /var/www/html/formalms/lib/lib.bootstrap.php on line 141

alfa24
Senior Boarder
Posts: 1006
Joined: Fri Nov 24, 2017 8:45 am
Version: forma.lms 1.4.2

Re: Installation stuck at 7/8 Screen

Post by alfa24 »

Check permission and existence of file config.php in the root folder of your installation path.
I'm Jasmines, the One. If you need, you can contact me.

rudy
FormaLms User
Posts: 33
Joined: Fri Nov 29, 2019 7:33 am

Re: Installation stuck at 7/8 Screen

Post by rudy »

in the install folder, i dont have any config.php and also in formalms/lib folder, whereas in the formalms folder, it has only, config.dist.php file. i have not deleted that file. Yes on first screen it has issued warning that config.php could not be write.

I have restarted the installation and it gave this warning regarding the config file, please let me know which folder i need to give permission to remove this warning shown in the link below.

https://scrn.li/S5G0743FkPoyA2

also 0755 permission to formalms folder with write to apache owner is given

alfa24
Senior Boarder
Posts: 1006
Joined: Fri Nov 24, 2017 8:45 am
Version: forma.lms 1.4.2

Re: Installation stuck at 7/8 Screen

Post by alfa24 »

Before starting the installation, rename config.dist.php to config.php and chmod it 777
I'm Jasmines, the One. If you need, you can contact me.

rudy
FormaLms User
Posts: 33
Joined: Fri Nov 29, 2019 7:33 am

Re: Installation stuck at 7/8 Screen

Post by rudy »

thanks but it again stuck at 7th screen:

https://scrn.li/06i99842lqz61K

alfa24
Senior Boarder
Posts: 1006
Joined: Fri Nov 24, 2017 8:45 am
Version: forma.lms 1.4.2

Re: Installation stuck at 7/8 Screen

Post by alfa24 »

That could be related to LMS issues with phpmailer you already posted. Bypass SMTP saying "no" to the first drop-down and install. You will choose to debug and fix SMTP issues later.
I'm Jasmines, the One. If you need, you can contact me.

rudy
FormaLms User
Posts: 33
Joined: Fri Nov 29, 2019 7:33 am

Re: Installation stuck at 7/8 Screen

Post by rudy »

ok, i actually thought that this new version will be bug free... that y changed by subscription to paid one... anyways, will see, however, even after no is is not enabling the button.

https://scrn.li/7crSr54nSrM5BX

alfa24
Senior Boarder
Posts: 1006
Joined: Fri Nov 24, 2017 8:45 am
Version: forma.lms 1.4.2

Re: Installation stuck at 7/8 Screen

Post by alfa24 »

Nothing is bug free, especially open source.
I have no 2.4.2 version to tell you if there's a new bug within that function.
I can say only that 2.4.1 is bugged with phpmailer SSL parameters.
I'm Jasmines, the One. If you need, you can contact me.

rudy
FormaLms User
Posts: 33
Joined: Fri Nov 29, 2019 7:33 am

Re: Installation stuck at 7/8 Screen

Post by rudy »

ok.. thanks...hope scorm tracking issue will be resolved in this...i know it is off topic, my reason for taking this new one is scorm tracking also

User avatar
max
FormaLms Guru
Posts: 2405
Joined: Thu Mar 01, 2012 10:41 am
Version: forma.lms 2.4
Contact:

Re: Installation stuck at 7/8 Screen

Post by max »

rudy wrote:
Sat Aug 15, 2020 3:35 pm
ok, i actually thought that this new version will be bug free... that y changed by subscription to paid one... anyways, will see, however, even after no is is not enabling the button.

https://scrn.li/7crSr54nSrM5BX
what you are experiencing is not a bug
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
https://www.elearnit.net
https://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
Skype: m_ferrari_it

Post Reply