Update issue Version 1.4.3 to version 2.3 (Step 2)

Install and configure FormaLMS and DoceboCE
Post Reply
chrisand6
Newbie
Posts: 4
Joined: Mon Apr 16, 2018 2:53 pm
Version: forma.lms 1.4.2

Update issue Version 1.4.3 to version 2.3 (Step 2)

Post by chrisand6 »

Attempting Update to version 2.3. from version 1.4.3

Using XAMPP with PHP 7.0.15, apache 2.4.25 and mariadb Server version: 10.1.21 (attempting a normal 'installation' with this configuration works fine). I am also migrating my XAMPP version from using PHP 5.5 to this newer version at the same time.

I have moved over my previous config.php file (and the /files folder). The update wizard stops on step 2 (after I choose the 'language').

But I get the following MySQL error from the PHP class:

Fatal error: Uncaught Error: Call to undefined function mysql_connect() in C:\xampp\htdocs\formalms\db\drivers\docebodb.mysql.php:28 Stack trace: #0 C:\xampp\htdocs\formalms\db\lib.docebodb.php(77): Mysql_DbConn->connect('localhost', 'formalms', 'xxxxxxx..', 'formalms') #1 C:\xampp\htdocs\formalms\db\lib.docebodb.php(495): DbConn::getInstance(NULL) #2 C:\xampp\htdocs\formalms\upgrade\controllers\Step2Controller.php(89): sql_get_client_info() #3 C:\xampp\htdocs\formalms\upgrade\views\Step2.php(4): Step2Controller->checkRequirements() #4 C:\xampp\htdocs\formalms\upgrade\controllers\StepController.php(20): include_once('C:\\xampp\\htdocs...') #5 C:\xampp\htdocs\formalms\lib\installer\lib.step.php(58): StepController->render() #6 C:\xampp\htdocs\formalms\upgrade\index.php(63): StepManager::loadCurrentStep() #7 {main} thrown in C:\xampp\htdocs\formalms\db\drivers\docebodb.mysql.php on line 28

My first suspicion is that FormaLMS is using the old, depracated mysql_connect() function, which was depracated 2 years ago and removed in PHP version 7.0. Do I have to install the 'old' .dll as part of PHP? Readme notes say that the update should detect the version of database and utilize the mysqli driver instead... but maybe its not?

I have double checked my connection credentials, and I am fairly certain that they are correct. I had to update one of the usernames for slightly different ... could this parameter be stored in 2 locations within the installation/update routine?

Any thoughts on what might be the problem with the update wizard for this configuration? Thank you in advance for the help!

-Chrisand6

alfa24
Senior Boarder
Posts: 1006
Joined: Fri Nov 24, 2017 8:45 am
Version: forma.lms 1.4.2

Re: Update issue Version 1.4.3 to version 2.3 (Step 2)

Post by alfa24 »

Change to mysqli in config.php
I'm Jasmines, the One. If you need, you can contact me.

chrisand6
Newbie
Posts: 4
Joined: Mon Apr 16, 2018 2:53 pm
Version: forma.lms 1.4.2

Re: Update issue Version 1.4.3 to version 2.3 (Step 2)

Post by chrisand6 »

Thanks! That did it!

I didn't think the cfg[dbtype] parameter was designating the method of connection.

Post Reply