GUI upgrade from 1.4 to 2.3

Install and configure FormaLMS and DoceboCE
Post Reply
alfonsowong
Newbie
Posts: 3
Joined: Wed Oct 04, 2017 9:58 am
Version: forma.lms 1.4.2

GUI upgrade from 1.4 to 2.3

Post by alfonsowong »

Hi All, I am currently using LMS 1.4.3. As I have already customized some of the programs, is there a simple way to just upgrade the user interface to 2.3?

If I follow the upgrade instruction, I encounter the following error after login. Does anyone has any clue? Thanks in advance!

>>>> Update: I fix it after adding "require_once(_lms_.'/lib/lib.course.php');" in lib.lms_block_menu.php <<<<


Warning: Missing argument 3 for Certificate::canRelExceptional(), called in /var/www/html/lms/appLms/lib/lib.certificate.php on line 318 and defined in /var/www/html/lms/appLms/lib/lib.certificate.php on line 423

Warning: Missing argument 3 for Certificate::canRelExceptional(), called in /var/www/html/lms/appLms/lib/lib.certificate.php on line 318 and defined in /var/www/html/lms/appLms/lib/lib.certificate.php on line 423

Fatal error: Call to undefined function getCourseTypes() in /var/www/html/lms/widget/lms_block/lib.lms_block_menu.php on line 225

User avatar
max
FormaLms Guru
Posts: 2405
Joined: Thu Mar 01, 2012 10:41 am
Version: forma.lms 2.4
Contact:

Re: GUI upgrade from 1.4 to 2.3

Post by max »

Hi, the templates for Forma 1.X cannot work with Forma 2.X, they have been deeply modified.
So, there is no simple way to have Forma 1 with Forma 2 GUI.

You just have to upgrade, you will not lose anything of your customizations.

Concerning the update you did to your post: I understand that you now solved?
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
https://www.elearnit.net
https://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
Skype: m_ferrari_it

alfonsowong
Newbie
Posts: 3
Joined: Wed Oct 04, 2017 9:58 am
Version: forma.lms 1.4.2

Re: GUI upgrade from 1.4 to 2.3

Post by alfonsowong »

Thanks Max but I have modified some programs in Forma 1.4 under \appLms which will be replaced after upgrade.

Yes, I have solved the exception by including the library. I just not sure if this is my setup issue only or a bug.

User avatar
max
FormaLms Guru
Posts: 2405
Joined: Thu Mar 01, 2012 10:41 am
Version: forma.lms 2.4
Contact:

Re: GUI upgrade from 1.4 to 2.3

Post by max »

Don't know if it's a bug or just a set up issue.
Anyway, whatever changes you make by hardcoding programs will always be lost after upgrading. Don't know what you're talking about, but it would be better to use customscripts or plugin to ensure future compatibility.
---------------------
Massimiliano Ferrari
Elearnit - Elearning e Knowledge Management
https://www.elearnit.net
https://www.linkedin.com/in/massimilianoferrari
m.ferrari[at]elearnit.net
Skype: m_ferrari_it

Post Reply