Help Please - White Screen only

Install and configure FormaLMS and DoceboCE
Stewart
FormaLms User
Posts: 34
Joined: Tue Sep 10, 2013 7:18 pm

Help Please - White Screen only

Post by Stewart »

Was looking at some site settings I think in the ecommerce screen and clicked Undo, now all I get is a white screen even when going to the main URL to login can this be fixed?

jasmines
Senior Boarder
Posts: 277
Joined: Fri May 03, 2013 12:29 pm

Re: Help Please - White Screen only

Post by jasmines »

Yes.
Please, activate debug in the config.php file and refresh. You will get a fatal error.
Provide that error and we'll try to help.

Stewart
FormaLms User
Posts: 34
Joined: Tue Sep 10, 2013 7:18 pm

Re: Help Please - White Screen only

Post by Stewart »

Thank you for your reply, please can you tell me the steps to activate debug?

jasmines
Senior Boarder
Posts: 277
Joined: Fri May 03, 2013 12:29 pm

Re: Help Please - White Screen only

Post by jasmines »

Open config.php and change the following line:

$cfg['do_debug'] = false;

to:

$cfg['do_debug'] = true;

Stewart
FormaLms User
Posts: 34
Joined: Tue Sep 10, 2013 7:18 pm

Re: Help Please - White Screen only

Post by Stewart »

Thank you......the result is below.

Warning: Illegal string offset 'browser' in /storage/ssd4/680/2127680/public_html/VLE/lib/layout/lib.layout.php on line 226

Warning: include(/storage/ssd4/680/2127680/public_html/VLE/templates//layout/home_login.php): failed to open stream: No such file or directory in /storage/ssd4/680/2127680/public_html/VLE/lib/layout/lib.layout.php on line 229

Warning: include(): Failed opening '/storage/ssd4/680/2127680/public_html/VLE/templates//layout/home_login.php' for inclusion (include_path='/storage/ssd4/680/2127680/public_html/VLE/addons/htmlpurifier/standalone:.:/usr/share/pear:/usr/share/php') in /storage/ssd4/680/2127680/public_html/VLE/lib/layout/lib.layout.php on line 229

jasmines
Senior Boarder
Posts: 277
Joined: Fri May 03, 2013 12:29 pm

Re: Help Please - White Screen only

Post by jasmines »

Nothing else?

Stewart
FormaLms User
Posts: 34
Joined: Tue Sep 10, 2013 7:18 pm

Re: Help Please - White Screen only

Post by Stewart »

That's is all that appears when navigating to the home page of the LMS

User avatar
CisterNino
FormaLms User
Posts: 69
Joined: Mon May 06, 2013 2:59 pm

Re: Help Please - White Screen only

Post by CisterNino »

Hi Stewart.
Try this:
go on your forma database and run this query
SELECT * FROM 'core_setting' WHERE `param_name` = 'defaultTemplate';
then tell me the result.
I'm Livio, the Two. If you need, you can contact the one.

Stewart
FormaLms User
Posts: 34
Joined: Tue Sep 10, 2013 7:18 pm

Re: Help Please - White Screen only

Post by Stewart »

Get SQL error

#1054 unknown column defaultTemplate in where clause

jasmines
Senior Boarder
Posts: 277
Joined: Fri May 03, 2013 12:29 pm

Re: Help Please - White Screen only

Post by jasmines »

semicolon missing, I suppose...

try this (semicolon included):

SELECT * FROM core_setting WHERE param_name = "defaultTemplate";

Post Reply