[SOLVED] Suddenly Unable to Register New Users

Backend functionalities: user management, course management, reports, certificates, etc.
Senior Boarder
Posts: 1006
Joined: Fri Nov 24, 2017 8:45 am
Version: forma.lms 1.4.2

Re: Suddenly Unable to Register New Users

Post by alfa24 »

Ok, let's remove the var_dump at 1448 e let's put it at 1794.

Code: Select all

return $errors;

Code: Select all

return var_dump($errors);
I'm Jasmines, the One. If you need, you can contact me.

Posts: 8
Joined: Mon Jun 15, 2020 9:30 pm

Re: Suddenly Unable to Register New Users

Post by AndrewL »

Alpha24, thank you for all of your time and help. We finally figured out our problem.

We had done the initial setup of the database, etc. through Powershell, and we set the sql mode to an empty string with a Powershell command, which meant that it worked fine as long as we didn't restart our server. However, we had to do a shutdown at one point, which reset our server, meaning the sql mode reverted to its default, but since the installation was already complete, it didn't give us any flags/warnings/error messages about the sql mode.

When we realized what the problem was, we went into the my.ini file and edited the sql mode properly, so it won't change again. Now it's working fine.

Thank you again for your help!

Post Reply